What wallets are compatible with the L2?

Modified on: Thu, 11 Nov, 2021 at 5:04 PM

While Layer 2 (Polygon) will enable great benefits over Layer 1 (Ethereum) for our users, such as faster transactions at no cost, it is also notable that fewer wallets are compatible with Polygon in regards to minting and managing NFT domains.


Here is a list of the wallets from our apps page which will continue to be compatible with Layer 2, as well as those from the list that are currently incompatible. Please note that compatible wallets are still required to be manually configured to work with Polygon.


Compatible wallets:



Incompatible wallets:


  • Trust Wallet (on iOS)

  • Opera

  • Moralis

  • Ownbit

  • Coinomi

  • AToken

  • Nimiq

  • DID Wallet

  • Orchid

  • Cake Wallet




Still need help?

Submit a Support Ticket

Join us on social media

with us